빌드오류 관련 질문드립니다


#1

우선 오픈프레임웍스 한글포럼이 생겨서 너무 반갑습니다
질문은 빌드가 성공적으로 이루어지던 모든 파일들이 다음의 이유로 실행이 안되고 있습니다
한가닥 희망의 코멘트 부탁드립니다~


#2

혹시 openframeworks를 applications 즉 응용프로그램 경로에 설치하셨나요 ? 해당경로에 쓰기권한문제가 있는건 아닌지 의심되네요. 근데 윈도우같은 운영체제가 그렇고 맥은 그렇지 않았던것 같은데…

빌드하려는 프로젝트가 이전 버전일 경우 빌드가 되지 않는 경우도 있습니다.


#3

답글 감사합니다~ 외장하드에 두고 맥에서 실행해 왔었습니다 버전도 그대로 …실행되던 예제파일까지 모두 같은 오류가 나네요.


#4

0.9. 이후 버전부터는 대다수의 빌드에러들은 projectorGenerator 로 해결 될 겁니다.
한번 시도해 보세요.
projectoGenerator


#5

네~projectorGenerator로 새 프로젝트 빌드해보았습니다 여전히 같은 오류 메세지가 뜨네요


#6

흠 그렇군요. 기본으로 있는 예제도 마찬가지라면, 혹시 어떤 작업을 하신 후에 에러가 생겼나요?
oF 업데이트나 혹은 Xcode 업데이트를 하셨는지…
아니면 oF 0.9.3 의 파일 용량은 얼마되지 않으니 새로 다운 받아 거기에서도 에러가 생기는 지도 한번 점검해보는 것도 방법일 듯 합니다.


#7

경로 문제라면 컴파일 단계에서 에러가 났을텐데,
이것은 링크 단계에서 에러가 난거네요.

이런 경우는 당해보지 않아서 모르겠습니다만, 일단

  • 프로젝트의 Build Settings의 Architectures와 Base SDK 세팅 및
  • 프로젝트 내에 링크된 openFrameworksLib.xcodeproj의 Settings의 Architectures와 Base SDK 세팅을 체크해 보시기 바랍니다.

그리고

  • 프로젝트의 Build Phases 세팅에서 “Target Dependencies” 부분에 "openFrameworks (openFrameworksLib)"이라는 부분이 있는지 체크해 보세요.

#8

oF 나 Xcode 업데이트는 한적없고 제가 작업하면서 경로문제를 일으킨것 같습니다
Build Settings의 Architectures와 Base SDK체크해보니


제 os x 는 10.10인데 10.11으로 되어있네요 The other에서 10.10SDK는 없다고 뜨네요 .osx를 업데이트를 해야하나요?
Target Dependencies부분에openFrameworks (openFrameworksLib)은 없는걸로 확인됩니다다


#9

올려주신 이미지를 보니 의심되는 게 있네요.
이 파일은 존재하나요?

경로는 yanny님의 경우라면 아래와 같습니다. finder에서 확인해보세요.
/Volumes/+yanny/Applications/of_v0.9.3_osx_release/libs/openFrameworksCompiled/project/osx/

만약 존재하는데도 그런다면…
저같은 경우 아주 가끔 xcode에서 여러 개의 프로젝트를 열었을 경우 처음 연 프로젝트 이외는 이런 에러가 발생할 때가 있었습니다.
해결 방법으로는 xcode를 종료하시고 사용하실 한개의 프로젝트만 열면 링크가 괜찮아지는 경우도 있었습니다. :slight_smile:


#10

아! 네 정말 파일이 존재하지 않네요

사라진 파일을 어떻게 생성시킬까요?


#11

http://openframeworks.cc/download/ 에서 새로 다운받아 복사하시는게 어떨지요? :grin:


#12

드디어자알 돌아갑니다~^^한분한분의 코멘트가 큰 힘이 되었습니다~외롭지 않는 ㅎㅎ 이 환경에 또 감사드립니다:heart_eyes: