Xcode 이전 버전에서 빌드가 되지 않는 문제


#1

안녕하세요 먼저 OF한글포럼 오픈을 축하드립니다
첫 질문은 제가 올리게 되어 영광입니다 :slight_smile:
입문 첫날부터 이런 곳을 알게되어서 더욱 기쁘네요

질문입니다

제가 가지고 있는OS가 10.6이라서요
Xcode 3.2를 깔고 OF도 압축을 푼 뒤
예제 프로젝트를 빌드시켜보면 항상 build failed가 뜨면서 결과물이 아예 뜨질 않습니다

debug가 아닌 release로 선택시켜놓았는데도 그러네요…

제가 완전 쌩 초보라서
해외 포럼에서도 어떻게 해결하는지 찾지도 못하고 있는 상황이라;;

한글포럼에서라면 도움을 받을 수 있지 않을까 해서 올려봅니다! 도와주세요!

그냥 OS 업데이트하고 최신버전의 xcode를 까는게 최선일까요?;


#2

oF 버전이 어떻게 되는지요 ?

에러로그를 올려주시면 좀 도움이 될것 같네요

xCode 버전이 낮다면 차라리 Qt Creator를 사용하는 방법은 어떨지 싶습니다.


#3

안녕하세요, 답변 감사합니다
OF는 최신 버전인 0.9.0을 설치했습니다
에러로그가 9만개가 넘는데,
가장 많이 나오는 것은 No such file or directory와
'~~was not declared in this scope 입니다;
Qt Creator로도 한번 시도해 보겠습니다 !


#4

oF가 최신 버전인데 비해 Xcode 3.2는 너무 옛날 버전이라 ㅠㅠ
아마 error와 warning 들을 해결해 나가기가 쉽지 않으실 것 같아요.

가능한 한 최신 Mac OS X과 Xcode를 설치하시고 마음에 평정을 얻으심이… ^^;;;